What browser can I use with SAP Concur?

Browsers certified for use with the Employee Reimbursement System are:

  • Microsoft Internet Explorer version 11
  • Microsoft Edge
  • Firefox versions 53, 54, & 55
  • Safari versions 5.1, 6.0, 7.0, 8.0, 9.0, & 10.0
  • Google Chrome versions 59, 60, & 61